<img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=931099456970389&amp;ev=PageView&amp;noscript=1">

Azure Managed Instance Cancelled DeploymentIn yesterday’s post, I made an important point that Azure Managed Instance deployments can take some time. It that demo/screen share, I showed that my first one took 1 day, 13 hours to deploy. This didn’t work as I had intended when I deployed, and yes, I got a bit impatient.

Today I’ll go back into my demo/screen share and a bit more into how my impatience got the best of me and what happened from there. By the way, as I talked about in my last post, Microsoft does give you a warning message that this may take over 24 hours to deploy.

You can see on my screen that I have a testpocmi and a testpocmi02; these were my first attempts at a new managed instance within my subscription. When I went to deploy this, I did so through a template as well as through the portal. This was taking hours upon hours, I got impatient and cancelled the deployment before it completed – a big mistake on my part.

The cancelling of this deployment has made it interesting in removing this resource group from my environment. To go back a step, there are some things we need to set up prior to deploying a managed instance.

I click on the virtual network I set up within this resource group. When you deploy a managed instance, you need to have some prerequisites. One of them is setting up its own subnet within a virtual network. So, I set up a subnet and if I go back to my testpocmi resource group, you’ll see that I have two resources there – a virtual cluster that was deployed to my subnet and my vlane that has the subset within it.

If I go to my subnet and try to remove it, I get an error message telling me ‘Failed to delete subnet’ which tells me that something is still associated with this particular subnet. Through some troubleshooting, it appears that this virtualclusterdbsubnet is still associated with that subnet, so when I try to delete my resource group, it will not do anything for me.

When I click on that virtualclusterdbsubnet, it tells me how many managed instanced I have, in this case it’s zero since I cancelled it. There’s nothing I can do to remove the subnet – I tried PowerShell and resources within PowerShell to get rid of the virtual network and even tried to force remove the entire resource group – nothing worked. It would run for hours, then fail.

I currently have a support ticket open with Microsoft. They did tell me that after 7 days, if nothing is part of this virtualclusterdbsubnet, that it should delete automatically, but that has not happened.

I’m still working on an answer and I will post again with respect to this issue. I believe the moral here is, have patience with your first managed instance deployment and give it the 24+ hours to complete. As I said in my last post, the benefits of Azure Managed Instance greatly outweigh the wait time.

If you’d like to learn more about the benefits of Azure Managed Instance or anything Azure related, we’re here to help. Click the link below or contact us for help from any of our Azure experts.

New Call-to-action
bg-img14.jpg

Join Our Blog

Join thousands of other SQL Server, BI and cloud pros by subscribing to our blog.

Leave a comment

Posts by Topic

see all

Recent Articles

Popular Articles